接続が IPv4 で届いたため、IPv6 アドレスがないか、IPv6 が優先されていません。
パブリックアドレス: ウェブサイトからはこのアドレスで見えます。多くの家庭やオフィスの回線では、同じルーターの配下にあるすべての端末で共有されます。
ネットワーク範囲を計算するならIPサブネット計算機をどうぞ。
接続が IPv4 で届いたため、IPv6 アドレスがないか、IPv6 が優先されていません。
パブリックアドレス: ウェブサイトからはこのアドレスで見えます。多くの家庭やオフィスの回線では、同じルーターの配下にあるすべての端末で共有されます。
ネットワーク範囲を計算するならIPサブネット計算機をどうぞ。
IT サポートに聞かれる、取引先がホワイトリストに登録したい、VPN やファイアウォールのルールに必要になる。このページは、接続そのものから直接読み取った、あなたの接続が使っているグローバル IP アドレスを表示し、どんな種類のアドレスかを説明します。
ノート PC には通常、ルーターが割り当てた 192.168.1.23 や 10.0.0.15 のようなプライベートアドレスがあります。これらの範囲は何百万もの家庭やオフィスで使い回されているため、どのサイトにも見えません。サイトや取引先のファイアウォール、IP 許可リストが見るのは、ルーターやプロバイダーが通信に付けるグローバルアドレスで、ここに表示されているものです。取引先からホワイトリスト用に IP を求められたら、これを送ってください。
グローバル IPv4 アドレスが 100.64 から 100.127 で始まる場合(RFC 6598 の 100.64.0.0/10 ブロック)、プロバイダーは 1 つの実アドレスを多数の利用者で共有しています。この場合、自分のルーターでポートを開けても意味がありません。手前にプロバイダーの機器があるからです。一般的な対処は、プロバイダーにグローバル IPv4 アドレスを依頼する、双方が対応していれば IPv6 を使う、トンネルサービスを使う、のいずれかです。
今では多くの回線が両方を持っています。アクセス先のサイトはどちらかを選ぶため、IPv4 アドレスだけを登録した許可リストでは、ブラウザーが IPv6 で接続したときにブロックされることがあります。IPv4 が許可されているのに拒否される場合は、ここに表示された IPv6 アドレスも追加するか、/64 プレフィックスの許可を依頼してください。IPv6 アドレスの末尾は変わることがあります。
ほとんどのファイアウォールやクラウドコンソールは範囲を CIDR 表記で求めるため、IPv4 アドレス1つは /32 を付けて 203.0.113.7/32 のように書き(ドキュメント用に予約されたアドレス)、IPv6 アドレス1つは /128 を付けます。IPv6 アドレスの末尾 64 ビットは、端末が一時的なプライバシーアドレス(RFC 8981)を使うためよく変わり、1つの IPv6 アドレスだけを許可するルールは1日で効かなくなることがあります。代わりに /64 プレフィックス、つまり完全表記の先頭4グループを許可します。例: 2001:db8:1234:5678::/64。/64 はそのネットワーク上のすべての端末を含むので、パスワードや鍵も要求するシステムに限って使ってください。/24 のような広い範囲に何が含まれるかは IPサブネット計算機で確認できます。
家庭用やモバイル回線の多くは動的アドレスで、再接続時、ルーター再起動後、または定期的にプロバイダーが変更することがあります。許可リスト用に固定アドレスが必要なら、プロバイダーに固定 IP を申し込むか、専用アドレス付きの VPN を使ってください。
はい。VPN がオンのときは VPN サーバーのアドレスが表示され、他のすべてのサイトもそのアドレスを見ています。VPN をオフにして再読み込みすると、プロバイダーのアドレスが表示されます。
パソコンはローカルネットワーク上で通常プライベートアドレス(192.168.x.x など)を持っています。ルーターがそれを 1 つのグローバルアドレスに変換し、サイトや許可リストにはそちらが見えます。
いいえ。このページを作るために接続から読み取るだけで、データベース、ログ、利用記録には一切書き込みません。
アドレスの場所を調べるには第三者のデータベースに送る必要があり、その推定は数百キロずれることもよくあります。このページはアドレスをこのサーバー内だけで扱います。
どれも同じアドレスを別の形で書いたものです。203.0.113.7 は1つの10進数にすると 3405803783 で、一部のデータベースやログはこの形で保存します。7.113.0.203.in-addr.arpa は逆引き DNS(PTR)の問い合わせに使う名前で、4つの部分が逆順になっています。このページは名前を組み立てるだけで問い合わせはしません。PTR レコードがあるかは nslookup 203.0.113.7 または dig -x 203.0.113.7 で確認できます。
このページに表示されるのはグローバル(公開)アドレスです。ローカルアドレスはルーターが割り当て、端末自身だけが知っています。Windows:コマンドプロンプトで ipconfig を実行し、IPv4 アドレスの行を見ます。Mac:ターミナルで ipconfig getifaddr en0 を実行するか(en0 は通常 Wi-Fi)、Wi-Fi 設定の「詳細」を開きます。Linux:hostname -I か ip -4 addr を実行します。Android と iPhone:接続中の Wi-Fi ネットワークの詳細を開きます。ローカルアドレスは通常 192.168.、10.、または 172.16 から 172.31 で始まり(RFC 1918 のプライベート範囲)、ルーターがアドレスを割り当て直すと変わることがあります。
多くの場合、そうです。GDPR (規則 (EU) 2016/679) の前文第30項は、個人と結び付けられるオンライン識別子の一つとしてIPアドレスを挙げており、欧州司法裁判所は Breyer 事件 (C-582/14、2016年10月19日) で、動的アドレスであっても、インターネット接続事業者を通じて訪問者を特定する法的手段を持つウェブサイト運営者にとっては個人データになり得ると判断しました。EUでは、サーバーログ、許可リスト、サポートチケットに残るアドレスを個人データとして扱うのが最も安全です。このページはアドレスをあなたに表示するためだけに読み取り、保存しません。